V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
cosint
V2EX  ›  Apple

App store 软件需求 ios16 以上

  •  
  •   cosint · 2023-06-12 23:28:19 +08:00 · 2483 次点击
    这是一个创建于 401 天前的主题,其中的信息可能已经有所发展或是发生改变。

    如题,ios16 有什么特别的地方?现在很多 App Store 里的软件都要求 ios16 以上,甚至 openai 这样的大厂也要求 ios16 ,当年 ios15 刚出来也没这么大的阵仗啊...

    15 条回复    2023-06-14 01:34:23 +08:00
    Leonard
        1
    Leonard  
       2023-06-12 23:31:27 +08:00
    可能是软件用的某些 API 是 iOS 16 才支持的?
    okakuyang
        2
    okakuyang  
       2023-06-12 23:36:20 +08:00
    开发的时候用了新版本的 swiftui ,没有做旧版本的支持。像今年 17 里的 swiftui 出来更多新功能,新出的 app 马上就会不支持 ios16
    dmql
        3
    dmql  
       2023-06-13 00:04:43 +08:00 via iPhone
    十有八九都是用了 swiftui ,好多以前 uikit 早就有的功能 swiftUI 拖到 iOS16 才实现,比如 scrollview 的下拉刷新功能。iOS17 又有新的更适合 swiftui 数据持久化实现的方法,开发者想用只能限定 iOS17
    alexcding
        4
    alexcding  
       2023-06-13 01:50:17 +08:00
    之前的 SwiftUI 功能不够完成, 4.0 (16.0) 比较完善
    xtinput
        5
    xtinput  
       2023-06-13 07:56:42 +08:00
    swiftui 开发的
    berresume
        6
    berresume  
       2023-06-13 08:16:48 +08:00
    16 的占有率也比较高吧
    shervy
        7
    shervy  
       2023-06-13 08:26:50 +08:00
    我到现在都是 15.6.1 ,是不是应该直接升级 ios17
    CodingIran
        8
    CodingIran  
       2023-06-13 09:17:22 +08:00
    很多使用 SwiftUI 开发的 App 都会尽量拉高版本号,因为 SwiftUI 每年的变化都特别大,一些好用的 API 都是只支持最新的系统,因此开发者在可能的情况下都不愿去适配老的系统。
    princeofwales
        9
    princeofwales  
       2023-06-13 09:41:24 +08:00   ❤️ 1
    为了能用巨魔,坚持 iOS14 不动摇
    TUTU2014
        10
    TUTU2014  
       2023-06-13 09:59:50 +08:00
    我的 iPadPro 11 吋(2018 ),还是 iPadOS13.7 呢,就怕升级以后报废,即便现在有些软件已经因不满足最低系统版本而无法更新。
    gniviliving
        11
    gniviliving  
       2023-06-13 10:01:06 +08:00
    @princeofwales 14 不是可以越狱吗,巨魔还是麻烦了点,但是比越狱安全和稳定
    Hanson666
        12
    Hanson666  
       2023-06-13 15:22:23 +08:00
    @gniviliving ios 越狱后再安装巨魔,两个都有了
    Deffi
        13
    Deffi  
       2023-06-13 16:29:42 +08:00
    用 SwiftUI 没办法,iOS 15 各种小问题
    princeofwales
        14
    princeofwales  
       2023-06-13 22:58:44 +08:00
    @gniviliving 是可以越狱,但是越狱后不稳定,iOS 自带的 APP ,有时会莫名其妙出问题,重启后才恢复。而且,现在很多 APP 都可以检测到已经越狱过,要么闪退要么部分功能不能用,装了一堆反检测的插件也不能解决所有的问题,还有 5G 信号会在越狱模式下经常中断。现在只用巨魔,比越狱简单多了
    GabrielleBellamy
        15
    GabrielleBellamy  
       2023-06-14 01:34:23 +08:00
    SwiftUI:系统升级→用户发现旧软件有 bug→反馈给开发者→开发者发现那是因为新系统不支持旧的 SwiftUI 的写法,开一次 WWDC 就变一次写法→决定开始按照新格式改代码→想要新的编译环境得先升级系统→升级了系统,新的代码只有新系统才能编译,旧系统认不出来爆 bug→本软件只限最新系统的用户使用。

    下一次:开发者提前升级了测试版→提前用新代码升级了软件→等系统发布之后第一时间推送软件更新→没升级的用户:你们这些软件怎么都要最新系统啊!

    苹果:嘿嘿,用户的系统更新率又创了新高。

    PS:不是只有新系统才是好系统,用旧系统没什么不好。被绑上系统更迭的贼船未必就是“进步”。

    你想要过怎样的生活呢?
    关于   ·   帮助文档   ·   博客   ·   API   ·   FAQ   ·   实用小工具   ·   3497 人在线   最高记录 6679   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 39ms · UTC 04:20 · PVG 12:20 · LAX 21:20 · JFK 00:20
    Developed with CodeLauncher
    ♥ Do have faith in what you're doing.