V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
Distributions
Ubuntu
Fedora
CentOS
中文资源站
网易开源镜像站
CheekiBreeki
V2EX  ›  Linux

Centos 7 被強制安裝旧内核

  •  
  •   CheekiBreeki · 2020-03-15 20:07:40 +08:00 via Android · 3556 次点击
    这是一个创建于 1057 天前的主题,其中的信息可能已经有所发展或是发生改变。

    目前是最新内核,清理了旧 3.1 内核。并在 yum 里屏蔽了 Kernel 安装。原来是最小安装没有 Gui,现在安装 yum groupinstall "GNOME Desktop" "Graphical Administration Tools"时,老是报错,卡在安装 Kernel 3.1 位置。Kernel 3.1 必须安装吗?能否跳过?

    13 条回复    2020-03-17 09:35:40 +08:00
    asilin
        1
    asilin  
       2020-03-15 20:40:57 +08:00
    内核没有清理干净导致的,还存留着旧的内核的一些包,看下 -devel 和 -headers 等包,卸载即可解决。
    CheekiBreeki
        2
    CheekiBreeki  
    OP
       2020-03-15 21:52:16 +08:00 via Android
    @asilin 都在 kernel 列表里是没有其他版本内核了
    CheekiBreeki
        3
    CheekiBreeki  
    OP
       2020-03-15 21:52:54 +08:00 via Android
    @asilin 直接 Skip 了,看看能否可以
    CheekiBreeki
        4
    CheekiBreeki  
    OP
       2020-03-15 22:01:03 +08:00 via Android
    @CheekiBreeki 还是不行
    V69EX
        5
    V69EX  
       2020-03-15 22:23:00 +08:00   ❤️ 2
    你不直接把报错的英文信息贴出来,别人怎么分析嘛……
    CheekiBreeki
        6
    CheekiBreeki  
    OP
       2020-03-16 00:13:18 +08:00 via Android
    @V69EX 他就是要装 3.1 内核,我就是不要他装
    vk42
        7
    vk42  
       2020-03-16 02:38:11 +08:00
    @CheekiBreeki 查一下哪个包依赖 3.1 的内核?一般很少有特定内核版本依赖的,感觉你这个跟显卡驱动有关
    csdreamdong
        8
    csdreamdong  
       2020-03-16 09:35:49 +08:00
    sudo yum -y remove kernel-tools-libs kernel-headers
    我觉得,你是卡在这 2 个包中的其中一个?
    卸载掉 3.1 的,然后装对应你的 kernel 版本的
    cstj0505
        9
    cstj0505  
       2020-03-16 10:19:27 +08:00
    为啥非要 centos,其他版本 Linux 不香嘛,内核随便升级
    joyhub2140
        10
    joyhub2140  
       2020-03-16 10:27:12 +08:00
    装 centos8。
    LokiSharp
        11
    LokiSharp  
       2020-03-16 10:36:20 +08:00
    桌面的话还是用 Fedora 吧。。。
    ps1aniuge
        12
    ps1aniuge  
       2020-03-16 21:58:18 +08:00
    扔掉 centos !!! linux 桌面 deepin 不香么?
    CheekiBreeki
        13
    CheekiBreeki  
    OP
       2020-03-17 09:35:40 +08:00 via Android
    @csdreamdong 没有的,老版本早清理完了,不知道哪个东西需要 3.1。我已经放弃桌面,反正也用不着
    关于   ·   帮助文档   ·   博客   ·   API   ·   FAQ   ·   我们的愿景   ·   广告投放   ·   实用小工具   ·   782 人在线   最高记录 5497   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 108ms · UTC 17:10 · PVG 01:10 · LAX 09:10 · JFK 12:10
    Developed with CodeLauncher
    ♥ Do have faith in what you're doing.