V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
OpenWrt 是一个专门面向嵌入式设备的 Linux 发行版。你可以将 OpenWrt 支持的型号的嵌入式设备,比如各种路由器上的系统,换成一个有更多可能性可以折腾的 Linux 系统。
OpenWrt 官方网站
DataPipe
V2EX  ›  OpenWrt

OpenWRT 自己编译的固件,后续如何安装源中的软件

  •  1
     
  •   DataPipe · 39 天前 · 488 次点击
    这是一个创建于 39 天前的主题,其中的信息可能已经有所发展或是发生改变。

    自己编译的固件,如何方便的使用源安装一些软件,因为会报 kernel 和 dependecy 版本不一致,无法安装。需要自己维护一个源?

    当然可以选择自己在编译固件的时候一起编译,但是有些软件是后来才有的需求,所以自己编译的固件有没有办法方便的从源中安装新软件?

    5 条回复
    qazwsxkevin
        1
    qazwsxkevin  
       39 天前
    不知道有无理解错,luci web 上有包管理,可以后续选择安装。。。。
    HughZadora
        2
    HughZadora  
       39 天前 via iPhone
    单独编译软件就好了
    lostman1337
        3
    lostman1337  
       38 天前
    自己编译的时候不要指定内核版本就行了
    Djlion
        4
    Djlion  
       32 天前
    make menuconfig 然后把要编译的软件包用空格键切成 M ,然后保存,比如我选择了 iperf 软件包,我单独编译 make package/iperf/compile V=99 -j32 ,编译完然后去 bin/targets/XXX/YYY/packages/去找对应的 ipk 。拷贝到设备的/tmp 目录下,然后 opkg install /tmp/软件包.ipk ,就可以用了。或者把软件包放到自己 web 服务的目录下,然后 opkg install 软件包的 url 。其他软件也是差不多,不用整个重新打固件。
    kmzs
        5
    kmzs  
       27 天前 via Android
    编译的时候用发布的正式版(现在最新的版本是 23.05.3 )就可以正常安装。不选版本的时候默认是 snapshot 版,这个版本的官方仓库提供的是随源码更新的。
    关于   ·   帮助文档   ·   博客   ·   API   ·   FAQ   ·   实用小工具   ·   2813 人在线   最高记录 6679   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 23ms · UTC 14:14 · PVG 22:14 · LAX 07:14 · JFK 10:14
    Developed with CodeLauncher
    ♥ Do have faith in what you're doing.