V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
测试工具
SmokePing
IPv6 访问测试
yuban10703
V2EX  ›  宽带症候群

上海电信 IPTV 使用 udpxy 的问题

  •  
  •   yuban10703 · 49 天前 · 1657 次点击
    这是一个创建于 49 天前的主题,其中的信息可能已经有所发展或是发生改变。

    目前是友华的 SDN 猫改了桥接,路由器是 openwrt

    目前的问题是 IPTV 如果一直在看的话没有问题(测试了一晚上,到早上还在正常播放)

    但是如果没有设备在播放的话,一段时间后就不能看了,重启 openwrt 里的 iptv 接口后就又能正常播放了

    很玄学,不知道哪里有问题...

    这是 udpxy 的设置

    这是 vlan85 的 iptv 接口

    第 1 条附言  ·  49 天前
    这是不能播放时候的 udpxy 日志
    https://pastebin.pl/view/f90e8ff4
    这是正常时候的日志
    https://pastebin.pl/view/8d5c2a0f
    第 2 条附言  ·  48 天前

    目前的解决方法是wget一直下载iptv的视频到/dev/null,这样就不会断线了......

    12 条回复    2022-06-29 18:27:11 +08:00
    FrankAdler
        1
    FrankAdler  
       49 天前 via iPhone
    我就默认配置勾上启用,下面的输入框全是空的?反正能用
    yuban10703
        2
    yuban10703  
    OP
       49 天前
    @FrankAdler 阿哲,我的一段时间没设备播放后就得重启接口才能播放...
    semglassiebaba
        3
    semglassiebaba  
       49 天前
    igmp_snooping 改成 0 试试,高效组播转发在某些路由器上是无效的,只会阻断组播
    yuban10703
        4
    yuban10703  
    OP
       49 天前
    jikky
        5
    jikky  
       49 天前
    你是不是 IPTV 也桥接了?
    yuban10703
        6
    yuban10703  
    OP
       49 天前
    @jikky SDN 的猫,我也不知道里面咋设置的.....
    linuxyz
        7
    linuxyz  
       48 天前
    我用的是聯通不知道是否可以藉鑒!

    兩點你可以看看:

    1 ,IPTV 這個 bridge 可以不用,也不需要走 VLAN 可以在上行連接光貓的端口上創建一個 DHCP 的 interface
    主要是我看你這個 bridge 的 IPv4 地址太神秘了,AT&T US 的地址不大可能出現在上海電信的地址池。
    通常光貓會在内部創建虛擬 VLAN 網卡終結 IPTV 的業務,Openwrt 這邊只要有正常的可以訪問光貓的内網 IPv4 地址就可以訪問 IPTV 的組播。
    添加的 interface 的 Firewall Zone 設置成 wan

    ```
    config interface 'iptv'
    option proto 'static'
    option device 'eth1'
    option netmask '255.255.255.0'
    option metric '2000'
    option ipaddr '192.168.1.8' # 根據你光貓的 LAN 地址配
    option gateway '192.168.1.1' # 根據你光貓的 LAN 的 Gateway 地址配
    option defaultroute '0'
    option delegate '0'
    ```


    2, 防火墻規則 需要 允許

    ```
    config rule
    option name 'Allow-IGMP'
    option src 'wan'
    option proto 'igmp'
    option family 'ipv4'
    option target 'ACCEPT'
    option device 'eth1'
    option direction 'in'

    config rule
    option src 'wan'
    option name 'Allow-IPTV'
    option family 'ipv4'
    list dest_ip '224.0.0.0/4'
    option target 'ACCEPT'
    list proto 'udp'
    option device 'eth1'
    option direction 'in'
    ```
    yuban10703
        8
    yuban10703  
    OP
       48 天前
    @linuxyz 感谢回答,上海电信的 IPTV 是单独一个 vlan 的....
    我目前用 wget 一直下载 iptv 的视频来实现不断线的.....
    raysonx
        9
    raysonx  
       44 天前
    建议直接去掉 iptv 这个 bridge,直接用 eth1.85 作 UDPXY 的上行端口,排除 bridge 的问题。
    raysonx
        10
    raysonx  
       44 天前
    此外要注意一下防火墙规则,允许从 eth1.85 input 方向和 forward 到 lan 的组播流量。
    Imsw93
        11
    Imsw93  
       44 天前
    你还可以保持一个 IPTV 盒子一直开机,就不会断了
    yuban10703
        12
    yuban10703  
    OP
       42 天前
    @raysonx 把桥接去掉了,直接用了单独的一个网口 eth3.85,能播放的话应该就说明防火墙规则没问题吧
    https://i.bmp.ovh/imgs/2022/06/29/fbdd514c5cde00dc.png
    关于   ·   帮助文档   ·   API   ·   FAQ   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   4138 人在线   最高记录 5497   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 152ms · UTC 09:37 · PVG 17:37 · LAX 02:37 · JFK 05:37
    Developed with CodeLauncher
    ♥ Do have faith in what you're doing.