V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
V2EX 提问指南
twofox
V2EX  ›  问与答

Copilot 在 IDEA 无法通过 GitHub 验证,如何解决?

  •  1
     
  •   twofox · 73 天前 · 1624 次点击
    这是一个创建于 73 天前的主题,其中的信息可能已经有所发展或是发生改变。

    貌似是新版的 bug ,不走 IDEA 的代理了,无法连接到 GitHub

    但是系统也有开全局代理,为什么还是不行( Windows10 + clash )

    现在退回旧版,会提示无法继续在此版本继续使用,太旧了

    image-20220607105316960

    <center>idea 会一直卡在这个界面</center>

    CSDN 的参考链接

    第 1 条附言  ·  73 天前
    图裂了,可以看 CSDN 里面的图
    24 条回复    2022-08-13 00:04:39 +08:00
    rimutuyuan
        1
    rimutuyuan  
       73 天前
    goland epa 我刚刚也搞了半小时,怎么切网络都不行。后来放弃了
    twofox
        2
    twofox  
    OP
       73 天前
    @rimutuyuan 我梯子开全局、用手机网络都不行
    Vaspike
        3
    Vaspike  
       73 天前
    https://plugins.jetbrains.com/plugin/17718-github-copilot/versions/stable/177247
    一样的问题:手动安装倒数第二个版本(上方链接),可以支持到 2022.2.EAP 版本的
    binhb
        4
    binhb  
       73 天前 via iPhone
    这个几乎就没成功过,我都是网页验证
    dcsuibian
        5
    dcsuibian  
       73 天前
    前段时间也遇到了,但完全不记得怎么解决的了。。。
    infinityv
        6
    infinityv  
       73 天前 via iPhone
    可能是顺序问题,你先把那个设备码复制好,点 OK 。再这个 Waiting 的页面再登录 github device ,输入你的设备码。等一会应该就好了
    rimutuyuan
        7
    rimutuyuan  
       73 天前
    @twofox 我按照 @infinityv #6 的方案成功登录了
    twofox
        8
    twofox  
    OP
       73 天前
    @rimutuyuan
    @infinityv
    我的还是不行
    @Vaspike 这个办法也不行

    我都不知道以前我怎么弄成功的 =.=
    Vaspike
        9
    Vaspike  
       73 天前
    @twofox #8
    淦,就在刚刚,提示我这个版本的 copilot 不能用了,必须升级,无语
    caotian
        10
    caotian  
       73 天前
    多试几次总会成功, 每次等一会儿不行就取消重新来, 幸运几次, 不幸运几十次
    iold
        11
    iold  
       73 天前 via iPhone
    新版本的 bug ,降级就可以了
    twofox
        12
    twofox  
    OP
       72 天前
    @Vaspike 我就说吧。。。
    @iold 降级之后会被强制升级,不升级不给用
    sardina
        13
    sardina  
       72 天前
    确实不行 还是用 vscode
    ql562482472
        14
    ql562482472  
       72 天前
    我昨天白天一直不行,晚上突然可以了
    lizytalk
        15
    lizytalk  
       72 天前 via iPhone
    降级,降到上一个版本就行,可以用
    PerFectTime
        16
    PerFectTime  
       72 天前   ❤️ 1
    检查你的 dns ,有可能相关的域名被解析到 127.0.0.1 了
    seesky
        17
    seesky  
       72 天前   ❤️ 1
    我是用 clash 开那个 tun 的代理解决的,
    iold
        18
    iold  
       72 天前 via iPhone   ❤️ 1
    @twofox #12 升级最新,我换了几次梯子节点,最后在湾湾的节点上成功了。
    RedBeanIce
        19
    RedBeanIce  
       72 天前 via iPhone   ❤️ 1
    我这边是 dns 问题
    olbb
        20
    olbb  
       71 天前   ❤️ 1
    可以试下 export http_proxy 设置代理
    eviladan0s
        21
    eviladan0s  
       71 天前   ❤️ 1
    把这几个域名的 IP 找到添加到 hosts 文件里即可,不用降级
    包括:
    github.com
    github.global.ssl.fastly.net
    api.github.com

    可以用这个网站找 IP 地址: https://www.ipaddress.com/
    加完记得刷新 DNS
    zjj19950716
        22
    zjj19950716  
       71 天前
    用了上面说的除了降级之外的所有方法终于成功了,全局代理 tun 模式+切节点+改 dns
    twofox
        23
    twofox  
    OP
       71 天前
    @eviladan0s 终于成功了!谢谢!
    duty
        24
    duty  
       6 天前
    @infinityv 方法可行,但我先讲缓存清除后再使用这种方式,也不确定需不需要清理缓存,但你的方法亲测可用,我的是最新的 ide
    关于   ·   帮助文档   ·   API   ·   FAQ   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   3076 人在线   最高记录 5497   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 23ms · UTC 10:36 · PVG 18:36 · LAX 03:36 · JFK 06:36
    Developed with CodeLauncher
    ♥ Do have faith in what you're doing.