V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
探索世界的好奇心万岁
sugz
V2EX  ›  分享发现

GitHub AI 编程工具 Copilot 已支持 IntelliJ IDEA、PyCharm 等

  •  
  •   sugz · 87 天前 · 1293 次点击
    这是一个创建于 87 天前的主题,其中的信息可能已经有所发展或是发生改变。
    该工具此前仅支持 Visual Studio Code ,在近日的 GitHub Universe 2021 开发者大会上,GitHub 官方宣布了 Copilot 的更新,已支持 Neovim 和 JetBrains IDE ,包含开发者常用的 IntelliJ IDEA 、PyCharm 等。

    要想使用 GitHub Copilot ,用户需将 IntelliJ IDEA 和 PyCharm 升级到 2021.2 或以上版本;而 Neovim 的版本则需为 0.6 或以上版本,并且需要安装 Node.js v12 或以上版本。
    6 条回复    2021-11-03 02:05:48 +08:00
    Reficul
        1
    Reficul  
       86 天前
    IDEA 只支持 2020.2 — 2021.1.3 ,最新的还没支持;
    CSM
        2
    CSM  
       86 天前
    会有 Emacs 版吗?
    yuuko
        3
    yuuko  
       86 天前
    写改 neovim 版本插件的作者对 neovim 嘲讽满满,他写 neovim 插件我是万万没想到的
    ysn2233
        4
    ysn2233  
       86 天前   ❤️ 1
    原生 vim 有支持吗?
    mauve
        5
    mauve  
       86 天前
    Goland 已经支持,亲测可用
    luckyx
        6
    luckyx  
       85 天前
    很早就支持了, 只不过在其他的 source 上
    关于   ·   帮助文档   ·   API   ·   FAQ   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   4136 人在线   最高记录 5497   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 30ms · UTC 06:20 · PVG 14:20 · LAX 22:20 · JFK 01:20
    Developed with CodeLauncher
    ♥ Do have faith in what you're doing.