V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
0576coder
V2EX  ›  Java

com.google.protobuf 无解的包冲突= =

  •  
  •   0576coder · 129 天前 · 991 次点击
    这是一个创建于 129 天前的主题,其中的信息可能已经有所发展或是发生改变。

    hbase-client 1.3.1 依赖 com.google.protobuf 的版本是 2.5.0

    正好要在项目里面增加 netty-grpc,为了调用其它部门的 grpc 接口

    但是 netty-grpc 依赖的 com.google.protobuf 最少都是 3.0.0 起的。

    所以没办法在同一个项目里用

    hbase 买的 tx 云的 升级不了大版本。比如说我只能从 1.3.1 升到 1.3.2

    瞬间无解 难受啊

    4 条回复    2021-07-23 00:18:16 +08:00
    guyeu
        1
    guyeu   129 天前
    没有什么是无解的,拆微服务、OSGI 、源码级别依赖都可以解决你的问题
    0576coder
        2
    0576coder   129 天前
    @guyeu
    拆了就麻烦 人少 我还是个 java 菜鸡= =
    如果无解的话 只能拆出去
    0576coder
        3
    0576coder   129 天前
    github 上看到别人也有一样的问题

    https://github.com/grpc/grpc-java/issues/3035

    我试试 hbase-shaded-client
    0576coder
        4
    0576coder   129 天前
    亲测有效 hbase-shaded-client

    回来回复一句
    关于   ·   帮助文档   ·   API   ·   FAQ   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   913 人在线   最高记录 5497   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 20ms · UTC 20:36 · PVG 04:36 · LAX 12:36 · JFK 15:36
    ♥ Do have faith in what you're doing.