V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
o2hard
V2EX  ›  C++

VSCode 误报语法错误

  •  
  •   o2hard · 69 天前 · 1260 次点击
    这是一个创建于 69 天前的主题,其中的信息可能已经有所发展或是发生改变。

    我在 mac osx 上用 vscode 写 c++,用的微软官方的 c++扩展,运行参数用的是g++ -std=c++2a。XCode 自带clang,输入g++会自动连接使用clang,我另外下了个gcc/g++,在zshrc中写入alias gcc='gcc-10' alias g++='g++-10',现在输入g++ --version显示的是g++-10 (Homebrew GCC 10.2.0) 10.2.0。我现在写一些 c++17 及以后的语法,比如std::vector arr; 程序编译运行没问题,但会有红色波浪线提示错误( argument list for class template "std::vector" is missing ),而且该段代码编辑器没有语法高亮。换成std::vector<int> arr;之后错误警告就消失了,代码的语法高亮也正确了。这是哪里设置出问题了,需要哪里再另外设置吗?现在的代码语法检测用的好像没有用到最新的std

    4 条回复    2020-11-18 23:31:34 +08:00
    seasona
        1
    seasona   69 天前
    std::vector arr;没给模板参数类型是怎么能过编译的,就算是推导指引也得给个迭代器吧
    Athrob
        2
    Athrob   69 天前
    std::vector arr;真的能编译通过吗, https://en.cppreference.com/w/cpp/container/vector 这里也没有你说的这种声明啊.
    nightwitch
        3
    nightwitch   69 天前
    你说 std::vector arr{1,2,3}能编译过我信,std::vector arr;能编译过那我不信。
    Meltdown
        4
    Meltdown   69 天前 via Android
    差点以为新标准都不用指定类型了
    关于   ·   帮助文档   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   4486 人在线   最高记录 5497   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 25ms · UTC 09:48 · PVG 17:48 · LAX 01:48 · JFK 04:48
    ♥ Do have faith in what you're doing.