V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
Distributions
Ubuntu
Fedora
CentOS
中文资源站
网易开源镜像站
praynise
V2EX  ›  Linux

新的办公机打算上 ubuntu 了,想咨询一个各位,优麒麟如何?

  •  
  •   praynise · 2018-07-06 21:30:11 +08:00 · 5807 次点击
    这是一个创建于 2055 天前的主题,其中的信息可能已经有所发展或是发生改变。
    貌似优麒麟整合了很多符合国情的东东,请咨询一下各位有用的吗?还是原生 ubuntu 更好呢?
    小弟主要是想用 ubuntu 做 go 和 python 开发。用 ubuntu 想本机开发完编译好直接扔生产,比较方便,不用交叉编译…
    31 条回复    2018-07-09 16:22:23 +08:00
    tulongtou
        1
    tulongtou  
       2018-07-06 21:31:20 +08:00 via iPhone
    为什么不用交叉编译呢?
    cctrv
        2
    cctrv  
       2018-07-06 21:34:01 +08:00 via iPhone
    praynise
        3
    praynise  
    OP
       2018-07-06 21:34:51 +08:00
    @tulongtou 因为有些依赖 C 的东东没法交叉编译…例如我这边开发很多需要用到 oracle 的驱动,这个交叉编译就会报错
    praynise
        4
    praynise  
    OP
       2018-07-06 21:37:13 +08:00
    主要还是针对 go 开发,python 还是没有寻找到一个好的批量离线部署方式,现在越来越多的把 python 的工具用 go 重写了…
    pynix
        5
    pynix  
       2018-07-06 21:50:46 +08:00
    构建可以用 docker。。
    必须用 ubuntu 的话还是建议原生。。。。
    Immortal
        6
    Immortal  
       2018-07-06 22:06:29 +08:00
    强力推荐
    arch+i3
    一次折腾终身有益~
    huclengyue
        7
    huclengyue  
       2018-07-06 22:09:17 +08:00 via Android
    不推荐 arch 因为服务器基本没有用 arch 的
    townmu
        8
    townmu  
       2018-07-06 22:32:12 +08:00 via Android
    想用符合国情的直接上 deepin15.6
    Allan0423
        9
    Allan0423  
       2018-07-06 22:34:01 +08:00
    deepin15.6 回复你,表示挺舒服的
    nihiue
        10
    nihiue  
       2018-07-06 22:53:38 +08:00 via Android
    不想折腾就 ubuntu 18.04 or mint
    Hilong
        11
    Hilong  
       2018-07-06 22:55:08 +08:00
    mint 还可以的,优麒麟感觉必要性不是很大。
    caola
        12
    caola  
       2018-07-06 22:58:05 +08:00
    linux 桌面系统,最好用的就是 Deepin 没有之一
    kwanzaa
        13
    kwanzaa  
       2018-07-06 23:06:52 +08:00
    符合国情的那一点东西还不如看手机。
    mason961125
        14
    mason961125  
       2018-07-07 00:01:38 +08:00 via iPhone
    用 go 为什么还要 Linux ? ARCH=linux 不行嘛
    xmadi
        15
    xmadi  
       2018-07-07 00:04:55 +08:00 via iPhone
    符合国情 deepin 才是最符合国情的 至少现在网易云音乐搜狗输入法都是和他们家联合开发的 最关键的是有 qq 而且也是 debian 系的 基本上和 ubuntu 没有兼容性问题
    likuku
        16
    likuku  
       2018-07-07 00:06:26 +08:00
    想用符合国情的直接上... win10
    lwq974962192
        17
    lwq974962192  
       2018-07-07 00:25:20 +08:00 via Android
    mint 欢迎你
    actar
        18
    actar  
       2018-07-07 00:31:23 +08:00 via Android
    同 mint
    sxzzsf
        19
    sxzzsf  
       2018-07-07 11:43:26 +08:00
    gentoo
    lfs
    omph
        20
    omph  
       2018-07-07 12:49:53 +08:00
    用就用呗,能差多少
    jss
        21
    jss  
       2018-07-07 13:33:46 +08:00 via iPhone
    直接上 MacBook Pro 不好吗?
    huangzxx
        22
    huangzxx  
       2018-07-07 18:39:21 +08:00
    本机编译,直接扔生产

    那得看你生产什么系统呀?
    zzugyl
        23
    zzugyl  
       2018-07-07 21:21:25 +08:00
    原声 Ubuntu 或者 Deepin Linux 比较舒服。
    silenceshell
        24
    silenceshell  
       2018-07-08 08:59:14 +08:00 via iPhone
    Deepin 好。不过内存多大的?我是 8G 的但是经常内存不够用,Goland 比较耗内存
    zf144114
        25
    zf144114  
       2018-07-08 17:27:14 +08:00
    mint +1
    iamchi
        26
    iamchi  
       2018-07-08 21:32:38 +08:00
    不要浪费时间了
    wizardoz
        27
    wizardoz  
       2018-07-09 10:03:36 +08:00
    你似乎重新定义了交叉编译,交叉编译通常指的是跨 CPU 平台,如 x86 上编译 arm 程序 ppc 程序等。
    在 windows 上直接编译 linux 程序我不知道能不能行,但就算行,坑也肯定很多。
    就算在 linux 上开发的程序,在另一台 linux 上运行,我也会在运行的机器上重新编译一次,除非做成 rpm 或 pkg 包。
    否则不能保证依赖问题都被解决。
    284716337
        28
    284716337  
       2018-07-09 10:11:47 +08:00
    mint 吧
    captainjack
        29
    captainjack  
       2018-07-09 11:50:29 +08:00
    要么 ubuntu,要么 deepin linux
    不过 deepin linux 小 bug 挺多,特别双屏使用
    iyuli
        30
    iyuli  
       2018-07-09 14:08:26 +08:00
    建议还是用原生的吧.........不要问我为什么
    lzwt806
        31
    lzwt806  
       2018-07-09 16:22:23 +08:00
    麒麟包括(优麒麟)和(银河麒麟)我都有长时间测试过,两者区别是后者给企业用的,软件版本较旧,前者是普通民用的,软件较新,但质量太差。优麒麟 17.10 还算稳定,18.04 发部就测试了,问题很多,我在麒麟官网向管理员反馈,一个月之后再下载官方的 iso,反馈的问题依旧,所以不建议用优麒麟。

    银河麒麟我从今年 3 月~ 4 月深度订制过,当时的版本是 4.02-sp2 ( 2017-12-18 日发部),前前后后测试版本不小于 30 个,可谓测试充分。稳定还算稳定,但也有一些缺陷让我订制完也没用它。这个项目是天津麒麟公司做的,从 2015 年开始,3 年支持,2015 年时 mate 才发部 1.12.8 (好像是),所以银河麒麟就是基于这个 mate 版本订制的,存在读写设备严重缓存问题(或叫识别不良),另外复制文件时有很奇葩的问题,我都懒得向官方反馈了,反应了也没下文。

    所以一定要用 Linux 还是深度或 debian,Fedora (关闭更新),ubuntu-LTS(14 或 16)靠普点,不要 18.04 LTS,刚出测试就内部错误,瞬间秒删。
    关于   ·   帮助文档   ·   博客   ·   API   ·   FAQ   ·   我们的愿景   ·   实用小工具   ·   977 人在线   最高记录 6543   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 31ms · UTC 22:23 · PVG 06:23 · LAX 14:23 · JFK 17:23
    Developed with CodeLauncher
    ♥ Do have faith in what you're doing.