V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
推荐关注
Meteor
JSLint - a JavaScript code quality tool
jsFiddle
D3.js
WebStorm
推荐书目
JavaScript 权威指南第 5 版
Closure: The Definitive Guide
LinkedIn
Pastsong
V2EX  ›  JavaScript

jQuery 3.0.0 发布了

  •  
  •   Pastsong · 2016-06-10 18:30:04 +08:00 · 4638 次点击
    这是一个创建于 2298 天前的主题,其中的信息可能已经有所发展或是发生改变。
    23 条回复    2016-06-12 19:03:38 +08:00
    notgod
        1
    notgod  
       2016-06-10 18:55:25 +08:00
    中国好多 IE6 ie8 有毛线用
    jquery 2.x 我测试都好多访客出现 js 错误的提示
    然后我又降回去 1.12 的 latest versions 了
    loading
        2
    loading  
       2016-06-10 19:02:13 +08:00 via Android
    @notgod 淘宝在解决这个问题,很快了!
    InFaNg
        3
    InFaNg  
       2016-06-10 19:49:58 +08:00 via Android
    人生苦短
    jquery 大法好
    codevn
        4
    codevn  
       2016-06-10 19:50:58 +08:00 via iPhone
    @notgod 同感。
    cevincheung
        5
    cevincheung  
       2016-06-10 19:52:46 +08:00
    @notgod 不是说最高 1.8.*才支持 ie8 及以下么。
    Pastsong
        6
    Pastsong  
    OP
       2016-06-10 19:59:17 +08:00   ❤️ 1
    @cevincheung 1.x 都是 IE 6+ 的支持
    Wangxf
        7
    Wangxf  
       2016-06-11 02:31:44 +08:00
    还好我已经半年没开发 PC 前端了,一直呆在无线部门,不过碰到了更恶心的微信和 uc 。。。
    realpg
        8
    realpg  
       2016-06-11 08:06:45 +08:00
    good 。
    已经将项目的 jquery2.x 升级
    owt5008137
        9
    owt5008137  
       2016-06-11 09:18:57 +08:00 via Android
    变化真它喵大,我只是拿 js 写写小工具的都好几个工具得改写法了
    cashew
        10
    cashew  
       2016-06-11 10:43:10 +08:00
    根本不支持 IE6 、 7 、 8
    hantsy
        11
    hantsy  
       2016-06-11 14:23:41 +08:00
    居然还支持 IE 。。。

    JQuery 要高效,就必须利用最新浏览器的 ES 6 成果(最新的 FF , Edge , Chrome 都完成了 90%以上 ES 6 规范),删除那些不必要的 polyfill 代码。
    Pastsong
        12
    Pastsong  
    OP
       2016-06-11 14:34:01 +08:00
    @hantsy 中国还有 20% 用户在用 IE <= 8 啊,这可是 ES5 都没支持好的浏览器啊...
    realpg
        13
    realpg  
       2016-06-11 17:09:35 +08:00
    @Pastsong
    实践证明 当你告诉他们 IE 不支持并告诉他们 firefox 360 搜狗高速 chrome 都可以的时候
    他们秒就打开了早就装好的搜狗、 360 ……
    kideny
        14
    kideny  
       2016-06-11 21:56:35 +08:00
    银行和电商,估计 50 年都不会用上 jq3.0 。
    lozio
        15
    lozio  
       2016-06-12 09:42:25 +08:00
    @kideny 淘宝已经不支持 ie8 了
    andy0620
        16
    andy0620  
       2016-06-12 10:01:16 +08:00
    @Pastsong 你说的 20%确实存在(数字精确度不考虑),不过不能把所有上网用户做基数来考虑,而应该从产品面向的用户素质来考虑。
    比如各种做技术的官网,就完全没有必要支持低版本浏览器,因为上那些网站的人如果 low 到用 ie678 的话,去那网站也没啥意义;但换个角度来说,比如一个做古旧书古董的电商,那肯定要着重兼容 ie678 的,因为这产品面向的用户普遍为高龄人群,会用个电脑就不错了,现在还用着 xp 也太正常了。


    @kideny 亲,你这想法肯定是错的。
    1 是,你看我国互联网才发展了几年就已经到了现在这个高度了?
    2 是,从平稳退化的角度来说,很快 jQuery3.0 兼容低版本浏览器的插件就会出来了。
    joshyu8
        17
    joshyu8  
       2016-06-12 13:44:39 +08:00
    @notgod 如果需要支持 IE6/7/8 ,那么请选择 1.9 http://blog.jquery.com/2012/06/28/jquery-core-version-1-9-and-beyond/
    jon
        18
    jon  
       2016-06-12 13:45:35 +08:00
    360 淘宝赶紧灭了 ie678 把
    notgod
        19
    notgod  
       2016-06-12 13:48:57 +08:00
    @joshyu8

    怎么还在盯这点破事
    你们都不看官方文档的吗?

    https://jquery.com/browser-support/
    If you need to support older browsers like Internet Explorer 6-8, Opera 12.1x or Safari 5.1+, use jQuery 1.12.

    不是很清楚的写了 1.12.*

    你官方博客找个 2012 年 6 月发的文章是怎么个意思
    那时候还没 1.12

    不要误导别人 认为只有<1.9 的才支持 IE6 IE8
    joshyu8
        20
    joshyu8  
       2016-06-12 14:12:48 +08:00
    @notgod 赞。
    aksoft
        21
    aksoft  
       2016-06-12 17:51:52 +08:00
    还是这个实在
    dxcqcv
        22
    dxcqcv  
       2016-06-12 18:17:56 +08:00
    @Pastsong 你告诉我,为什么淘宝敢抛弃 20%的用户,还是你数据有问题?
    Pastsong
        23
    Pastsong  
    OP
       2016-06-12 19:03:38 +08:00
    关于   ·   帮助文档   ·   API   ·   FAQ   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   4438 人在线   最高记录 5497   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 45ms · UTC 05:51 · PVG 13:51 · LAX 22:51 · JFK 01:51
    Developed with CodeLauncher
    ♥ Do have faith in what you're doing.