V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
guoqiao
V2EX  ›  Ubuntu

Ubuntu 16.04 终于发布了, 来谈谈你的升级体验

  •  
  •   guoqiao · 2016-04-22 05:16:01 +08:00 · 22077 次点击
    这是一个创建于 2356 天前的主题,其中的信息可能已经有所发展或是发生改变。
    156 条回复    2016-04-30 15:59:15 +08:00
    1  2  
    iwdmb
        1
    iwdmb  
       2016-04-22 06:03:47 +08:00
    follow 一下帖子,晚上來升級看看!
    LeoSocks
        2
    LeoSocks  
       2016-04-22 07:19:01 +08:00 via Android
    @iwdmb 我也是,去升级,坐等大家的反馈
    janxin
        3
    janxin  
       2016-04-22 07:35:30 +08:00 via iPhone
    以前用 centos ,今天装了一个 server 玩,软件新到感动😹
    先是装了一堆测试环境必须,要长期跑跑看下效果了。
    mongodb 现在没有新版本, 3.x 要么自己编译要么等官方,我选择等…
    wsdjeg
        4
    wsdjeg  
       2016-04-22 07:37:14 +08:00
    各位,如果升级了 ubuntu16.04,请帮忙测试下遮盖 bug 是否还在;
    安装 neovim
    打开后, 输入 2 次 `:echom "test"`,再执行`:message`此时会在 message 区域显示,看看是否可以用鼠标左键选择 并按右键弹出选项卡,或者看此时按`print screen`键,这个区域是否会消失.
    emric
        5
    emric  
       2016-04-22 07:37:47 +08:00
    莫名把我的主板时间改成了 UTC ,还有 Chrome 安装出现未知错误。
    估计我人品太差了。
    emric
        6
    emric  
       2016-04-22 08:02:01 +08:00
    Tink
        7
    Tink  
       2016-04-22 08:21:15 +08:00 via iPhone
    今晚回去准备从 Server 14.04LTS 升级 16.04LTS ,不知道有没有坑
    itfanr
        8
    itfanr  
       2016-04-22 08:33:33 +08:00
    @wsdjeg 哈哈 你伸手党
    wsdjeg
        9
    wsdjeg  
       2016-04-22 08:35:54 +08:00 via Android
    @itfanr 目前电脑上是 arch,不高兴在重装了
    KaoN
        10
    KaoN  
       2016-04-22 08:55:25 +08:00
    装在虚拟机上发现鼠标显示不出来。。- -
    Testalias
        11
    Testalias  
       2016-04-22 09:00:26 +08:00
    时隔四年,再次体验 Ubuntu ,然而昨晚装到一半卡死了,怒删,不说了我去装 Gentoo 。
    zro
        12
    zro  
       2016-04-22 09:03:20 +08:00
    15.10 不能正常编译 OpenWRT ,有测试过 16.04 能正常编译的同学吗?
    prondtoo
        13
    prondtoo  
       2016-04-22 09:11:25 +08:00
    上上上,生产环境换换换。 MariaDB 10.1.13+PHP7.0.5+NGINX1.8.1 。感觉就像灰了起来一样。
    whatisnew
        14
    whatisnew  
       2016-04-22 09:25:02 +08:00
    @zro 估计是 python3 的依赖?
    Lxxyx
        15
    Lxxyx  
       2016-04-22 09:26:28 +08:00
    16.04 在哪儿可以安装 unity8 ?期待很久了
    mahone3297
        16
    mahone3297  
       2016-04-22 09:27:03 +08:00
    @prondtoo 哈哈,果然 php7 啊
    如何能做到不更新系统,直接更新 php 啊。。。不要自己编译。
    pimin
        17
    pimin  
       2016-04-22 09:27:12 +08:00
    UEFI 安装之后没启动起来
    不知道什么鬼
    shearer
        18
    shearer  
       2016-04-22 09:31:17 +08:00
    公司网络太慢,晚上回家用家里网络刷刷看
    itfanr
        19
    itfanr  
       2016-04-22 09:32:23 +08:00
    @wsdjeg 我用的 deepinlinux
    kiwi95
        20
    kiwi95  
       2016-04-22 09:38:53 +08:00
    @mahone3297 用第三方源, yum 的话可以用 webtatic.com 的源
    janxin
        21
    janxin  
       2016-04-22 09:40:28 +08:00
    值得一提的是外边都说默认 Python3.5 ,我安装完成之后发现 python 默认还是 Python 2.7.11 , python3 才对应 Python 3.5.1

    ```
    [email protected]:~$ python -V
    Python 2.7.11+
    [email protected]:~$ python3 -V
    Python 3.5.1+
    ```
    mahone3297
        22
    mahone3297  
       2016-04-22 09:59:29 +08:00
    @kiwi95 最好能有官方源,比较放心。
    ltm
        23
    ltm  
       2016-04-22 10:08:38 +08:00 via Android
    @janxin 真是这样我就不升了
    hzwjz
        24
    hzwjz  
       2016-04-22 10:22:38 +08:00
    @Lxxyx /t/273464
    >参考七楼
    hzwjz
        25
    hzwjz  
       2016-04-22 10:25:28 +08:00
    @pimin 不太懂你是不是这个原因,仅供参考。 Known issues : https://wiki.ubuntu.com/XenialXerus/ReleaseNotes#Known_issues
    hzwjz
        26
    hzwjz  
       2016-04-22 10:27:07 +08:00
    @janxin 该不会是要 clean and install 才可以吧?
    abutter
        27
    abutter  
       2016-04-22 10:34:35 +08:00
    @zro 你在 15.10 上编译 OpenWrt 哪个版本?错误是啥?
    starcraft
        28
    starcraft  
       2016-04-22 10:44:55 +08:00
    噫 装的 server 很不错啊 失败了一次 折腾了一下刚弄完 等晚上再爽爽
    qqmishi
        29
    qqmishi  
       2016-04-22 11:13:48 +08:00
    从 alpha 版就一直在用了,没什么大的感觉
    janxin
        30
    janxin  
       2016-04-22 11:13:55 +08:00
    @hzwjz 我是创建新虚拟机安装的,应该没有这个问题
    Tink
        31
    Tink  
       2016-04-22 11:13:57 +08:00 via iPhone
    有没有哪位是从 Server 版的 14.04lts 升上来了?
    mdzz
        32
    mdzz  
       2016-04-22 11:41:41 +08:00
    默认中文字体与英文字体不同高,这个要怎么改啊?我是小白用户
    20015jjw
        33
    20015jjw  
       2016-04-22 11:42:42 +08:00 via Android
    @janxin 本来 unix 里面 py 和 py3 就是分开的...
    ju5t4fun
        34
    ju5t4fun  
       2016-04-22 11:44:28 +08:00
    @janxin ReleaseNotes:Python2 is not installed anymore by default on the server, cloud and the touch images, long live Python3!
    Desktop 还是同时提供 python2 和 python3 两个版本。
    kslr
        35
    kslr  
       2016-04-22 11:45:36 +08:00   ❤️ 1
    我要从 14.04 直接升级到 16.04 了,大家等我回来
    janxin
        36
    janxin  
       2016-04-22 11:56:54 +08:00
    @20015jjw 锅应该算是那些写新闻稿的,都是一个口径 Python 默认 3.5
    Tink
        37
    Tink  
       2016-04-22 11:58:57 +08:00 via iPhone
    @kslr 求直播,我晚上回去升级家里的 micro server
    ju5t4fun
        38
    ju5t4fun  
       2016-04-22 12:01:06 +08:00
    @pimin It is currently impossible to boot a Xen hypervisor from grub in UEFI mode. However the package does not detect this and will set the default boot to Xen mode. So for any machine in UEFI mode, do not install the Xen hypervisor (or enable legacy mode first).
    codecrash
        39
    codecrash  
       2016-04-22 12:08:24 +08:00 via Android
    @kslr 不是说要到 16.04.1 才会有从 14.04lts 到 16.04
    大概三个月之后
    vtea
        40
    vtea  
       2016-04-22 12:12:00 +08:00 via iPhone
    感觉在 vbox 里速度比 14.04 快
    jackfu
        41
    jackfu  
       2016-04-22 12:16:53 +08:00
    从 16.04 beta2 升级,没有问题。
    另一个工作环境从 14.04 LTS 虚拟机升级, vmware-tools 不好使了,重装报错。折腾了很久,后来装了 open-vm-tools ,终于一切正常了。
    danmary61
        42
    danmary61  
       2016-04-22 12:24:17 +08:00
    白天先安装了麒麟 16.04 ,满心欢喜打开浏览器, duang !无法上网,折腾了几分钟,好烦呀,怒删之。
    晚上下了官方的,一切 OK 。还没来得及仔细研究。
    jedrek
        43
    jedrek  
       2016-04-22 12:31:11 +08:00
    安装 unity 8 输密码后进不了桌面
    Showfom
        44
    Showfom  
       2016-04-22 12:32:10 +08:00 via iPhone
    准备测试一段时间以后再在生产环境用
    Chrisplus
        45
    Chrisplus  
       2016-04-22 12:49:44 +08:00
    chrome 的中文字体晃瞎了我的眼睛!
    zro
        46
    zro  
       2016-04-22 12:50:50 +08:00
    @whatisnew 不太清楚呢,换回 15.04 就正常了,少了某些依赖?
    @abutter 编译最新版本,错误不太记得,反正./scripts/feeds update -a 运行会出错,而且错误是中文显示的
    bullettrain1433
        47
    bullettrain1433  
       2016-04-22 12:54:32 +08:00
    ubuntu 升级必跪,还是从新转吧
    Return2legacy
        48
    Return2legacy  
       2016-04-22 12:54:34 +08:00 via Android   ❤️ 1
    @zro beta2 上测试并没问题,正式版应该也同样可以的
    kslr
        49
    kslr  
       2016-04-22 13:03:57 +08:00 via Android
    @Tink 正在自动清理和安装升级
    kslr
        50
    kslr  
       2016-04-22 13:05:11 +08:00 via Android
    @codecrash 我打开了提前释出的更新,但依旧是 lts
    ecoart
        51
    ecoart  
       2016-04-22 13:09:53 +08:00 via Android
    @jedrek 我也是这种情况,准备重装系统了
    Tink
        52
    Tink  
       2016-04-22 13:10:54 +08:00 via iPhone
    @bullettrain1433 错误信息是什么?
    mathgl
        53
    mathgl  
       2016-04-22 13:12:40 +08:00
    @janxin 估计不敢这么激进, py3 现在估计 30%都不到。
    lzsadam
        54
    lzsadam  
       2016-04-22 13:13:06 +08:00
    Unity8 依旧丑
    MrLiao
        55
    MrLiao  
       2016-04-22 13:15:51 +08:00
    官网上直接下的 iso ,启动盘直接重装,把原本的 14.04 删除了,现在嗨着呢,感觉好多软件都没有了啊!
    Tink
        56
    Tink  
       2016-04-22 13:23:13 +08:00 via iPhone
    @jackfu 你从 14.04LTS 直接升级没什么大坑吧?
    lcqtdwj
        57
    lcqtdwj  
       2016-04-22 13:25:16 +08:00
    不敢升级,以前的经验, ubuntu 升级几乎都有问题
    kslr
        58
    kslr  
       2016-04-22 13:30:20 +08:00 via Android
    @Tink Gstreamer 已经炸了,正在想办法跳过
    qqmishi
        59
    qqmishi  
       2016-04-22 13:35:16 +08:00
    @qqmishi 哦对了,默认字体变得特别细,简直要瞎眼,建议自行换字体。
    billgreen1
        60
    billgreen1  
       2016-04-22 13:35:30 +08:00
    @bullettrain1433 重新转怎么保留软件包,我知道可以导出 pkglist ,但是应该不完美
    Chrisplus
        61
    Chrisplus  
       2016-04-22 13:39:12 +08:00
    @lcqtdwj 吸取教训,每次都是全新安装
    kslr
        62
    kslr  
       2016-04-22 13:44:20 +08:00 via Android
    @kslr Gstreamer 已经删掉,正在自动清理和卸载应用
    kslr
        63
    kslr  
       2016-04-22 13:47:50 +08:00 via Android
    @Tink 升级完成所有数据应用都在,除了 php5, mysql5 可能版本太低了吧,其他一切完美。
    abutter
        64
    abutter  
       2016-04-22 13:50:35 +08:00
    @zro 我一直用 15.10 编译 OpenWrt , target 是 ar71xx 。
    21grams
        65
    21grams  
       2016-04-22 14:02:32 +08:00
    为啥我升不了级? 按这个官方的升级文档: http://www.ubuntu.com/download/desktop/upgrade
    死活都找不到有新版本,这是怎么回事?
    alexfu
        66
    alexfu  
       2016-04-22 14:05:30 +08:00
    @ecoart 我也是。。重装了也没用。。
    SaulLawliet
        67
    SaulLawliet  
       2016-04-22 14:19:48 +08:00
    15.10 升到 16.04
    暂时只发现, chrome 的中文字体, 太细了. 我的眼睛 @[email protected]
    SaulLawliet
        68
    SaulLawliet  
       2016-04-22 14:23:55 +08:00   ❤️ 1
    youyoumarco
        69
    youyoumarco  
       2016-04-22 14:25:25 +08:00
    还有 unity...真是受够了
    Cu635
        70
    Cu635  
       2016-04-22 14:40:54 +08:00
    @21grams
    估计是你的 sources.list 里面用的源还没有同步。

    不过也有可能是你在 sources.list 里面用的是一个固定版本的代号,而不是 stable 这样的可升级的链接。

    多年不用 ubuntu ,不太确定了。
    zky001
        71
    zky001  
       2016-04-22 14:54:53 +08:00
    麒麟的扁平化风格我想直接换!!!!!!!
    Earthman
        72
    Earthman  
       2016-04-22 15:04:35 +08:00
    fcitx 是不是依赖 ibus 啊,装了不自动运行,手动运行后也没法切换
    Neveroldmilk
        73
    Neveroldmilk  
       2016-04-22 15:06:55 +08:00
    准备找个虚拟机装装试试,没敢升自己当前用的服务器。
    Tink
        74
    Tink  
       2016-04-22 15:10:29 +08:00 via iPhone
    @kslr php5 和 mysql 会直接升吗?
    Tink
        75
    Tink  
       2016-04-22 15:11:32 +08:00 via iPhone
    @kslr 哦对,你是 desktop 还是 server 版?
    kslr
        76
    kslr  
       2016-04-22 15:14:43 +08:00
    @Tink
    desktop

    有冲突的都被删除了,最更新最后一步可以看到冲突的列表,都是要卸载的
    Tink
        77
    Tink  
       2016-04-22 15:16:37 +08:00 via iPhone
    @kslr 晓得了!我晚上 server 升级!
    zeac
        78
    zeac  
       2016-04-22 15:17:07 +08:00
    @jedrek 我也是 下这个版本就是想体验一下 unity8 的
    ecoart
        79
    ecoart  
       2016-04-22 15:30:01 +08:00
    @alexfu 做 U 盘系统,全新安装不会有问题啊
    aa45942
        80
    aa45942  
       2016-04-22 15:33:45 +08:00
    出 16.04 了?我先升级下我的 centos 压压惊...

    话说 16 是不是还是像前几个版本那么臃肿,有安装直播么,前排瓜子等候
    qq7790586
        81
    qq7790586  
       2016-04-22 16:04:39 +08:00
    能 apt-get 直接升级吗?
    zhengkai
        82
    zhengkai  
       2016-04-22 16:20:44 +08:00
    升级是 sudo do-release-upgrade

    但我不建议现在装,除非你只跑系统本身,不然还是需要等周边的软件再基于新系统做些适应的
    Jiavan
        83
    Jiavan  
       2016-04-22 16:45:05 +08:00
    已体验,装完后我差点砸了室友的电脑
    zjhzxhz
        84
    zjhzxhz  
       2016-04-22 16:51:15 +08:00
    @jedrek The same problem here.
    sumuu
        85
    sumuu  
       2016-04-22 16:58:03 +08:00
    Checking for a new Ubuntu release
    No new release found
    用的是 "ustc.edu" 的源,下班后在家里电脑看下.
    4641585
        86
    4641585  
       2016-04-22 17:17:34 +08:00 via iPhone
    vps
    前段时间把 14.04 升级到了 dev branch 。今天直接更新到了 LTS 整个过程完全无痛。就是现在完全想不起来当初为什么要升上去…
    _(:_」∠)_
    kdplus
        87
    kdplus  
       2016-04-22 17:23:18 +08:00
    今天中午從 15.10 升上去的
    boot 不夠還擴容了一下(不小心刪掉了,想想升級的時候會重新裝就沒管 23333
    體驗:
    輕度用戶還沒啥體驗 2333...
    只想說側邊欄放 bottom 並不習慣....
    pzzrudlf
        88
    pzzrudlf  
       2016-04-22 17:30:00 +08:00
    @Jiavan 这是为何?难道不好用?
    Tink
        89
    Tink  
       2016-04-22 17:30:31 +08:00 via iPhone
    @Jiavan 为啥?
    initialdp
        90
    initialdp  
       2016-04-22 17:48:47 +08:00
    已安装体验,直观感觉和以前的版本没太大区别,没有 Unity8 ,也没有 MIR ,基本还是又丑又慢。

    很多库已经升级,可能导致程序不兼容。如果是生产环境,建议多做测试后再做决定是否升级。

    个人感觉这个版本没有以前 LTS 版本的兴奋感,是个鸡肋。
    akira
        91
    akira  
       2016-04-22 18:02:59 +08:00
    @janxin
    python -V
    The program 'python' can be found in the following packages:
    * python-minimal
    * python3
    Try: sudo apt install <selected package>
    Daddy
        92
    Daddy  
       2016-04-22 18:23:08 +08:00
    @prondtoo Nginx 1.8.1 差评,不支持 http2
    snriud
        93
    snriud  
       2016-04-22 19:16:57 +08:00
    升级到了 16.04,屏幕黑了。。。。。。。可以启动,可以进入到输密码的界面,输完密码登录就黑了。。。升级前还有代码没有提交。。。。
    Balthild
        94
    Balthild  
       2016-04-22 19:31:10 +08:00 via iPhone
    @emric 主板時間不是一直是 UTC 嗎…
    fyibmsd
        95
    fyibmsd  
       2016-04-22 19:31:58 +08:00
    mysql 挂了。。
    mwangzhy
        96
    mwangzhy  
       2016-04-22 19:58:35 +08:00 via Android
    @snriud 不知道是不是显卡的问题…… 16.04 现在没有 AMD 官方支持的显卡驱动,我的笔记本是 A 卡,装了 16.04 之后不能正常休眠唤醒,又装回 14.04 了
    janxin
        97
    janxin  
       2016-04-22 20:02:57 +08:00
    @akira apt install python 和 apt install python3 是两个不同的版本
    ZE3kr
        98
    ZE3kr  
       2016-04-22 20:10:04 +08:00 via iPhone
    我把我的 VPS 升上去了( Ubuntu Server ),一切顺利,之前的软件源都没了。顺便说一下 16.04 官方源支持 PHP7.0.4 (不是 7.0.5 )、 Nginx1.9.15 和 MySQL5.7 。还是不错的
    ZE3kr
        99
    ZE3kr  
       2016-04-22 20:10:38 +08:00 via iPhone
    @mahone3297 加一个第三方软件源,能装 php7.0.5 的
    ZE3kr
        100
    ZE3kr  
       2016-04-22 20:11:30 +08:00 via iPhone
    @prondtoo 你是 PHP7.0.5 吗?我这里还是 7.0.4-7ubuntu2
    1  2  
    关于   ·   帮助文档   ·   API   ·   FAQ   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   1004 人在线   最高记录 5497   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 59ms · UTC 19:04 · PVG 03:04 · LAX 12:04 · JFK 15:04
    Developed with CodeLauncher
    ♥ Do have faith in what you're doing.